Forcing Linux To Use Software OpenGL

If for whatever crazy reason, you want to force Linux to use a Software OpenGL implementation, simply run this command before launching your application:

export  LIBGL_ALWAYS_SOFTWARE=1

I needed to do this to run Godot Engine on an old laptop that had no hardware OpenGL implementation, and it works like a charm.